Acunetix Premium ADFS SSO integration not working

Symptoms:

The user can not log into the Acunetix account using the integration SSO.

 

Errors in the logs:

Backend logs:

ERROR frontend_api_resources.User SSO login failed, session_request failed:
The response was received at https://{target_URL}/api/v1/me/sso_login/U2FsdGVkX18StU4Ffg5V8MyQxjEN_OCiSE8Awv0LSS6JAv3csh4dGFKD18EJGBY9vCgIzKVjE221vwlmVj-uOA== instead of https://{target_URL}:443/api/v1/me/sso_login/U2FsdGVkX18StU4Ffg5V8MyQxjEN_OCiSE8Awv0LSS6JAv3csh4dGFKD18EJGBY9vCgIzKVjE221vwlmVj-uOA==

 

SAML trace logs:

ERROR sso.strategies.onprem_strategy SSO session request failed: A valid SubjectConfirmation was not found on this Response
ERROR sso.strategies.onprem_strategy SSO session request failed: A valid SubjectConfirmation was not found on this Response
ERROR frontend_api_resources.User SSO login failed, session_request failed: A valid SubjectConfirmation was not found on this Response


Root Cause:

Time mismatch between Acunetix SAML SSO and the Azure workstation.

 

Resolution:

Adjusting the time zone in the Azure workstation according to the timestamp within the SAML response which should be exported as SAML trace logs.

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